Browse Source

Use Ruby 2.7.2 (#15150)

thwait and e2mmap are no longer needed in Gemfile.
Gems properly require those.
master
Daigo 3 Dango 10 months ago
committed by GitHub
parent
commit
541b9f8c1c
No known key found for this signature in database GPG Key ID: 4AEE18F83AFDEB23
4 changed files with 2 additions and 7 deletions
  1. +1
    -1
      .ruby-version
  2. +1
    -1
      Dockerfile
  3. +0
    -3
      Gemfile
  4. +0
    -2
      Gemfile.lock

+ 1
- 1
.ruby-version View File

@ -1 +1 @@
2.6.6
2.7.2

+ 1
- 1
Dockerfile View File

@ -40,7 +40,7 @@ RUN apt update && \
cd .. && rm -rf jemalloc-$JE_VER $JE_VER.tar.gz
# Install Ruby
ENV RUBY_VER="2.6.6"
ENV RUBY_VER="2.7.2"
ENV CPPFLAGS="-I/opt/jemalloc/include"
ENV LDFLAGS="-L/opt/jemalloc/lib/"
RUN apt update && \

+ 0
- 3
Gemfile View File

@ -11,9 +11,6 @@ gem 'sprockets', '~> 3.7.2'
gem 'thor', '~> 1.0'
gem 'rack', '~> 2.2.3'
gem 'thwait', '~> 0.2.0'
gem 'e2mmap', '~> 0.1.0'
gem 'hamlit-rails', '~> 0.2'
gem 'pg', '~> 1.2'
gem 'makara', '~> 0.4'

+ 0
- 2
Gemfile.lock View File

@ -704,7 +704,6 @@ DEPENDENCIES
discard (~> 1.2)
doorkeeper (~> 5.4)
dotenv-rails (~> 2.7)
e2mmap (~> 0.1.0)
ed25519 (~> 1.2)
fabrication (~> 2.21)
faker (~> 2.14)
@ -793,7 +792,6 @@ DEPENDENCIES
streamio-ffmpeg (~> 3.0)
strong_migrations (~> 0.7)
thor (~> 1.0)
thwait (~> 0.2.0)
tty-prompt (~> 0.22)
twitter-text (~> 1.14)
tzinfo-data (~> 1.2020)

Loading…
Cancel
Save