Browse Source

Install npm 3 in docker (v3 warns on invalid peer dependencies instead of failing)

pull/4/head
Eugen Rochko 5 years ago
parent
commit
b0168c8f3c
2 changed files with 2 additions and 3 deletions
  1. +1
    -0
      Dockerfile
  2. +1
    -3
      package.json

+ 1
- 0
Dockerfile View File

@ -4,6 +4,7 @@ ENV RAILS_ENV=production
RUN echo 'deb http://httpredir.debian.org/debian jessie-backports main contrib non-free' >> /etc/apt/sources.list
RUN apt-get update -qq && apt-get install -y build-essential libpq-dev libxml2-dev libxslt1-dev nodejs nodejs-legacy npm ffmpeg && rm -rf /var/lib/apt/lists/*
RUN npm install -g npm@3
RUN mkdir /mastodon
WORKDIR /mastodon

+ 1
- 3
package.json View File

@ -10,9 +10,7 @@
"browserify-incremental": "^3.1.1",
"react": "^15.3.0",
"react-dom": "^15.3.0",
"react-proxy": "^1.1.8"
},
"dependencies": {
"react-proxy": "^1.1.8",
"axios": "^0.14.0",
"es6-promise": "^3.2.1",
"immutable": "^3.8.1",

Loading…
Cancel
Save