Browse Source

Update dependencies of Node.js (#3067)

* Update autoprefixer to version 7.1.0

* Update axios to version 0.16.1

* Update babel-cli to version 6.24.1

* Update babel-eslint to version 7.2.3

* Update babel-preset-react to version 6.24.1

* Update coffee-script to version 1.12.6

* Update css-loader to version 0.28.1

* Update express to version 4.15.2

* Update js-yaml to version 3.8.4

* Update mocha to version 3.4.1

* Update jsdom to version 10.1.0

* Update npmlog to version 4.1.0

* Update postcss-smart-import to version 0.7.0

* Update postcss-loader to version 2.0.5

* Update pg to version 6.1.5

* Update prop-types to version 15.5.10

* Update rails-ujs to version 5.1.1

* Update redis to version 2.7.1

* Update sass-loader to version 6.0.5

* Update stringz to version 0.2.0

* Update webpack to version 2.5.1

* Update style-loader to version 0.17.0

* Update sinon to version 2.2.0

* Update react-motion to version 0.5.0

* Update react-notification to version 6.7.0

* Update react-redux-loading-bar to version 2.9.0

* Update react-intl to version 2.3.0

* Update redux-immutable to version 4.0.0

* Update reselect to version 3.0.1

* Update react-toggle to version 3.0.1

* Update react-simple-dropdown to version 3.0.0

* Update react-router to version 3.0.5

* Update react-router-scroll to version 0.4.2

* Update react-toggle to version 4.0.1

* yarn upgrade
pull/4/head
Yamagishi Kazutoshi 5 years ago
committed by Eugen Rochko
parent
commit
e0ada97770
3 changed files with 1184 additions and 1211 deletions
  1. +33
    -32
      package.json
  2. +1
    -5
      spec/javascript/setup.js
  3. +1150
    -1174
      yarn.lock

+ 33
- 32
package.json View File

@ -19,9 +19,9 @@
},
"dependencies": {
"array-includes": "^3.0.3",
"autoprefixer": "^6.7.7",
"axios": "^0.15.3",
"babel-cli": "^6.23.0",
"autoprefixer": "^7.1.0",
"axios": "^0.16.1",
"babel-cli": "^6.24.1",
"babel-core": "^6.24.1",
"babel-loader": "7.x",
"babel-plugin-lodash": "^3.2.11",
@ -36,45 +36,46 @@
"babel-plugin-transform-react-remove-prop-types": "^0.4.5",
"babel-plugin-transform-runtime": "^6.23.0",
"babel-preset-env": "^1.4.0",
"babel-preset-react": "^6.11.1",
"babel-preset-react": "^6.24.1",
"classnames": "^2.2.5",
"coffee-loader": "^0.7.3",
"coffee-script": "^1.12.5",
"coffee-script": "^1.12.6",
"compression-webpack-plugin": "^0.4.0",
"css-loader": "^0.28.0",
"css-loader": "^0.28.1",
"dotenv": "^4.0.0",
"emojione": "^2.2.7",
"emojione-picker": "^2.2.1",
"es6-symbol": "^3.1.1",
"escape-html": "^1.0.3",
"express": "^4.14.1",
"express": "^4.15.2",
"extract-text-webpack-plugin": "^2.1.0",
"file-loader": "^0.11.1",
"font-awesome": "^4.7.0",
"glob": "^7.1.1",
"history": "^3.3.0",
"http-link-header": "^0.8.0",
"immutable": "^3.8.1",
"intersection-observer": "^0.2.1",
"intl": "^1.2.5",
"intl-relativeformat": "^1.3.0",
"is-nan": "^1.2.1",
"js-yaml": "^3.8.3",
"js-yaml": "^3.8.4",
"lodash": "^4.17.4",
"mark-loader": "^0.1.6",
"marky": "^1.2.0",
"mkdirp": "^0.5.1",
"node-sass": "^4.5.2",
"npmlog": "^4.0.2",
"npmlog": "^4.1.0",
"object-assign": "^4.1.1",
"path-complete-extname": "^0.1.0",
"pg": "^6.1.2",
"postcss-loader": "^1.3.3",
"postcss-smart-import": "^0.6.12",
"pg": "^6.1.5",
"postcss-loader": "^2.0.5",
"postcss-smart-import": "^0.7.0",
"precss": "^1.4.0",
"prop-types": "^15.5.8",
"prop-types": "^15.5.10",
"punycode": "^2.1.0",
"rails-erb-loader": "^5.0.0",
"rails-ujs": "^5.1.0",
"rails-ujs": "^5.1.1",
"react": "^15.5.4",
"react-addons-perf": "^15.4.2",
"react-addons-shallow-compare": "^15.5.2",
@ -82,30 +83,30 @@
"react-imageloader": "^2.1.0",
"react-immutable-proptypes": "^2.1.0",
"react-immutable-pure-component": "^0.0.4",
"react-intl": "^2.1.5",
"react-motion": "^0.4.5",
"react-notification": "^6.6.0",
"react-intl": "^2.3.0",
"react-motion": "^0.5.0",
"react-notification": "^6.7.0",
"react-redux": "^5.0.4",
"react-redux-loading-bar": "2.4.1",
"react-router": "^2.8.0",
"react-router-scroll": "^0.3.2",
"react-simple-dropdown": "^1.1.4",
"react-redux-loading-bar": "^2.9.0",
"react-router": "^3.0.5",
"react-router-scroll": "^0.4.2",
"react-simple-dropdown": "^3.0.0",
"react-textarea-autosize": "^5.0.6",
"react-toggle": "^2.1.1",
"redis": "^2.6.5",
"react-toggle": "^4.0.1",
"redis": "^2.7.1",
"redux": "^3.6.0",
"redux-immutable": "^3.1.0",
"redux-immutable": "^4.0.0",
"redux-thunk": "^2.2.0",
"requestidlecallback": "^0.3.0",
"reselect": "^2.5.4",
"reselect": "^3.0.1",
"rimraf": "^2.6.1",
"sass-loader": "^6.0.3",
"stringz": "^0.1.2",
"sass-loader": "^6.0.5",
"stringz": "^0.2.0",
"style-loader": "^0.16.1",
"throng": "^4.0.0",
"uuid": "^3.0.1",
"uws": "^0.14.5",
"webpack": "^2.4.1",
"webpack": "^2.5.1",
"webpack-bundle-analyzer": "^2.8.2",
"webpack-manifest-plugin": "^1.1.0",
"webpack-merge": "^4.1.0",
@ -113,20 +114,20 @@
},
"devDependencies": {
"@kadira/storybook": "^2.35.3",
"babel-eslint": "^7.2.2",
"babel-eslint": "^7.2.3",
"chai": "^3.5.0",
"chai-enzyme": "^0.6.1",
"enzyme": "^2.8.2",
"eslint": "^3.19.0",
"eslint-plugin-jsx-a11y": "^4.0.0",
"eslint-plugin-react": "^6.10.3",
"jsdom": "^9.11.0",
"jsdom": "^10.1.0",
"minimist": "^1.2.0",
"mocha": "^3.2.0",
"mocha": "^3.4.1",
"react-intl-translations-manager": "^5.0.0",
"react-storybook-addon-intl": "^0.1.0",
"react-test-renderer": "^15.5.4",
"sinon": "^1.17.6",
"sinon": "^2.2.0",
"webpack-dev-server": "^2.4.5"
},
"optionalDependencies": {

+ 1
- 5
spec/javascript/setup.js View File

@ -1,12 +1,8 @@
import { jsdom } from 'jsdom/lib/old-api';
import chai from 'chai';
import chaiEnzyme from 'chai-enzyme';
chai.use(chaiEnzyme());
/**
* http://airbnb.io/enzyme/docs/guides/jsdom.html
*/
var jsdom = require('jsdom').jsdom;
var exposedProperties = ['window', 'navigator', 'document'];
global.document = jsdom('');

+ 1150
- 1174
yarn.lock
File diff suppressed because it is too large
View File


Loading…
Cancel
Save